Firmware Update: Synology DSM 7.1.1-42962 – Computer – Downloads

Synology has released the final release of Disk Station Manager version 7.1.1. Synology DSM is the management software available on various nasthe company’s products. The disk and rack stations offer more than just extra storage space. For example, additional packages can be installed so that the device can function as e.g. media server, web server, print server or backup server. The possibilities are endless.

Before version 7.1.1 can be installed, at least version 7.0 must be present. Furthermore, it is only suitable for the NAS models whose model number ends with 13 or higher. Version 7.1 will also be the last update for models ending in 13, 14 or 15. Check this page for the other terms and the various downloads. Version 7.1.1 mainly contains bug fixes and security updates. The changelog for this release looks like this:

Important notes

  • From this version, the bad sector count column will not be displayed along with hard disk information. Users should go to each drive’s Health Info > History to see its complete bad sector information. To determine if bad sectors are affecting the drive, see if there is a significant increase in the number of bad sectors over time.
  • Adjusted how the system calculates the estimated lifetime of M.2 NVMe SSDs to provide a more accurate estimate.
  • Support for AAC encoded audio is widespread across end devices such as smartphones, tablets, computers and most other media playback devices. The need for AAC transcoding to achieve better compatibility has been significantly reduced and will be removed starting with DSM 7.1.1.
  • Surveillance Station must be updated to version 9.0.1-7673 or later to be compatible with this update.

What is new

  • Added support for recipient profiles for email notifications, allowing users to add multiple email addresses under each profile and customize rules for the profiles.
  • Users can now enable the quota setting for shared folders located on volumes with data deduplication enabled.
  • Added support for RAID arrays with 16 and 20 hard drives when creating RAID groups.
  • Supports checking the 2-factor authentication status of user accounts in Control Panel > User and Group > Users.
  • Added support for SR-IOV on the following Synology NICs: E10G21-F2, E25G21-F2.

Fixed issues

  • Fixed an issue where the “Enable UID/GID switching” option would be disabled after changing the user/group list refresh time interval on an LDAP client.
  • Fixed several security vulnerabilities regarding CIFS-utils (CVE-2022-27239, CVE-2022-29869).
  • Fixed a security vulnerability regarding OpenLDAP (CVE-2022-29155).
  • Fixed a security vulnerability regarding cURL (CVE-2022-22576).
  • Fixed a security vulnerability regarding Zlib (CVE-2018-25032).
  • Fixed a security vulnerability regarding Freetype (CVE-2022-27406).
  • Fixed several security vulnerabilities related to 802.1X (CVE-2021-30004, CVE-2021-30266).
  • Fixed several security vulnerabilities regarding the GNU C Library (CVE-2021-43396, CVE-2022-23218, CVE-2022-23219).
  • Fixed several security vulnerabilities related to YAML-cpp (CVE-2018-20573, CVE-2018-20574, CVE-2019-6285).
  • Fixed several Linux Kernel security vulnerabilities (CVE-2019-11477, CVE-2019-11478, CVE-2019-11479, CVE-2020-12770, CVE-2019-18282, CVE-2019-1952079, CVE-1952079 , CVE-1952079, CVE-2020-12770 CVE-2019-19537, CVE-2021-0605, CVE-2021-3732, CVE-2021-3739, CVE-2021-3753, CVE-2021-4149, CVE-2021- 4203, CVE-2017, CVE-2017, CVE-20171 2021-20321, CVE-2021-20322, CVE-2021-29154, CVE-2021-29650, CVE-2021-34556, CVE-2021-35477, CVE-2021 -39632, CVE-39632, CVE-201, CVE- 45868, CVE-2022-0185, CVE-2022-0330, CVE-2022-0617, CVE-2022-0847, CVE-2022-1011, CVE-2022-1048 , CVE-2022, C-10552, CVE-12502, CVE-2022-20008, CVE-2022-27666, CVE-2022-28893, CVE-2022-29582).
  • Updated OpenSSL to version 1.1.1o to fix several security vulnerabilities (CVE-2022-1292, CVE-2021-3712, CVE-2022-0778).
  • Updated libarchive to version 3.6.1 to fix several security vulnerabilities (CVE-2021-36976, CVE-2022-26280).
  • Updated Mbed-TLS to version 2.28 to fix several security vulnerabilities (CVE-2021-44732, CVE-2021-45450, CVE-2021-43666).
  • Updated Python to version 3.8.12 to fix several security vulnerabilities (CVE-2021-3733, CVE-2021-3737, CVE-2022-0391).
  • Updated Redis to version 6.2.7 to fix several security vulnerabilities (CVE-2022-24735, CVE-2022-24736).
  • Updated ISC DHCP to version 4.4.3 to fix a security vulnerability (CVE-2021-25217).

Leave a Comment